AVM FRITZBox Broadband VDSL and ADSL Routers in Security Glitch

Owners of the German (AVM) made FRITZ!Box home broadband routers, specifically models 3272, 7272, 3370/3390/3490, 7312/7412, 7320/7330 SL, 736x SL and the 7490, should ensure that they have the latest firmware (v6.30 or newer) in order to fix a nasty security exploit. FRITZ!Box routers have proven to be quite popular amongst more advanced users, not … Continue reading AVM FRITZBox Broadband VDSL and ADSL Routers in Security Glitch