Sponsored

Huawei CPE 5G Pro issues, help?

BcartwrightIy

Casual Member
Hi if I put my EE SIM card in my phone and tether to my Xbox I have no issues but if I put the exact same SIM card in my Huawei CPE 5G Pro I can download games but I can’t play online games or join or make a party and also YouTube or Netflix don’t work but Amazon Prime Video does.

also the same applies to my Amazon Echo speaker works fine tethered to my phone but doesn't work on the CPE Pro.

Any suggestions or help would be greatly appreciated
 

dfunked

Casual Member
Hi if I put my EE SIM card in my phone and tether to my Xbox I have no issues but if I put the exact same SIM card in my Huawei CPE 5G Pro I can download games but I can’t play online games or join or make a party and also YouTube or Netflix don’t work but Amazon Prime Video does.

also the same applies to my Amazon Echo speaker works fine tethered to my phone but doesn't work on the CPE Pro.

Any suggestions or help would be greatly appreciated
Could be a CGNAT related issue which seems to be the default for 5G connections, whereas 4G gives you a proper external IP.
Talk to EE and see if they can give you static IP would be my first thought.
 

BcartwrightIy

Casual Member
Could be a CGNAT related issue which seems to be the default for 5G connections, whereas 4G gives you a proper external IP.
Talk to EE and see if they can give you static IP would be my first thought.
unfortunately EE don't supply static IP addresses
 

Buggerlugz

ULTIMATE Member
Its quickly becoming pretty obvious that for gaming the ISP's don't want people using mobile data, isn't it?

I mean there is no reason why 5g has to be CGNAT at all. All they need to resolve this is to have two seperate APN's , one for mobile phone users using CGNAT and one for 5g home broadband users which does not.
 

BcartwrightIy

Casual Member
Its quickly becoming pretty obvious that for gaming the ISP's don't want people using mobile data, isn't it?

I mean there is no reason why 5g has to be CGNAT at all. All they need to resolve this is to have two seperate APN's , one for mobile phone users using CGNAT and one for 5g home broadband users which does not.
I’m currently using 4G
 

TTJJ

Top Member
Could it be the pesky IPv6 issue from the other thread that caused issues with IPv4?

Can you set your Huawei router to be IPv4 only. In Mobile Network Searching options you should have that option. Give it a few minutes after you've changed it and check your internet is still working. This way would be easier than changing your APN but there is that option too.

If you don't have that option, you could manually add a new APN with the following settings. This worked for another user experiencing some oddities with EE.

EE Mobile Internet APN Settings
Name: EE Internet
APN: everywhere
Username: eesecure
Password: secure
 

BcartwrightIy

Casual Member
Could it be the pesky IPv6 issue from the other thread that caused issues with IPv4?

Can you set your Huawei router to be IPv4 only. In Mobile Network Searching options you should have that option. Give it a few minutes after you've changed it and check your internet is still working. This way would be easier than changing your APN but there is that option too.

If you don't have that option, you could manually add a new APN with the following settings. This worked for another user experiencing some oddities with EE.

EE Mobile Internet APN Settings
Name: EE Internet
APN: everywhere
Username: eesecure
Password: secure
Thank you so much it has worked😁😁😁😁
 

TTJJ

Top Member
Thank you so much it has worked😁😁😁😁
This is becoming really interesting now. @Mark.J maybe it would be worth approaching EE regarding this? It seems EE's strange implementation of IPv4 over IPv6 is causing problems for a few different services such as here and in the Santander site not working thread.
 

Ray_88

Member
Thank you so much it has worked😁😁😁😁

Hi,

i have exactly the same issue and it seems to be this device. I am unable to connect my Smart TV and also Netflix does not work but Disney+ works on the Amazon Fire stick :/
In addition i am unable to access my works VPN...
EE are of no help, they try play ping pong asking to contact Huawei and Huawei seem to say its your network provider....

Can you please let me know how you managed to make it work? as in how you changed the IPv6 to IPv4? did you create a new APN? if so if you could please provide step by step on how you achieved this as i am new to IT terminologies such as APN etc...

Maybe provide a picture of the APN settings so i can copy to my router?

Thanks in advance for your help!

R
 

TTJJ

Top Member
Login to the router settings and go to Network, Mobile network settings and press the + and copy in the settings a few posts above that I posted. Save and activate the new APN and it seems to be the fix.
 

Ray_88

Member
Hi All just to let you know the solution of changing APN IP Type form ipv6 to ipv4 only worked a treat.

the following will help all on EE having issues with the Huawei CPE Pro:

Hello All,



just updating you all on my CPE Pro which had issues with connecting to certain elements such as my Smart TV, Netflix and work VPN.



so after doing some digging i have found a solution to which not even EE or Huawei were able to easily fix/recommend.



there is a easy fix to it and that fix is based on the APN. The way EE set this router is that they have set the ‘IP type’ to ipv4 or ipv6 and it is this IPv6 which is causing us all the issues. I managed to change the APN to only IPv4 which has completely resolved all issues 😊



so follow these steps and let me know if it works for you:



1. Login to the device admin framework 192.168.8.1, ensure you are connected to a laptop via ethernet and not wifi.



2. Go to Network Settings. Under Mobile Networks > Internet Connection. You will see Mobile Data is checked and Auto Select Network is checked. Uncheck the Auto Select.



3. Under APN list you will see there is a EE Internet as default which cannot be deleted/removed. Leave this there, hit the + sign next to APN List and create a new EE setting as follows:

- Name: ee internet (make sure lower case ee)

- user name: eesecure

- password: secure

- ************: PAP

- IP Type: IPv4 (select only IPv4 from dropdown)

- APN: everywhere



- keep ‘set DNS server manually’ as unchecked so its auto.



click save at bottom and now this will save as new default.



You will temporarily lose internet connection. Do not worry, read on...



4. Next go to Advanced (top right in ribbon) and then System > Restart. Hit restart. Your device will restart. You will temporarily lose internet connection. Now the important thing is to be patient! It will take about 10-15mins even after all the lights are back on the device until you slowly regain connection.



You can then do random checks on laptop to see if it is working. Disconnect ethernet and connect to wifi and test all the devices and sites that were not working previously and voila they should work!



Important to note:

if you switch device off and on again anytime, that new profile will stay as default so shouldn’t be any problem. However if you decide to reset the device (bottom of device with pin) then you will need to recreate the new APN profile again.





Now this seems to be an issue with this specific Huawei device in having difficulty switching between IPv6 to IPv4 when it is required. Best to just keep IPv4 as only option for now until they find a fix for that issue of being able to switch between the two IP Types without causing issues.



Hope the above helps as i could not find any step by step as per above anywhere. I had to piece together from various different forums.



let me know how you guys get along?!



Thanks

Ray
 

xxl

Member
hi , i have exactly the same problem but when i switch off IPv6 i am getting only 4g. Is the anyway to be on 5G when i have IPv4 only?
 
Top
Promotion
Cheapest Superfast ISPs
  • Hyperoptic £19.95 (*22.00)
    Avg. Speed 50Mbps, Unlimited
    Gift: Promo Code: HYPER20
  • SSE £22.00
    Avg. Speed 35Mbps, Unlimited
    Gift: None
  • xln telecom £22.74 (*47.94)
    Avg. Speed 66Mbps, Unlimited
    Gift: None
  • TalkTalk £22.95 (*29.95)
    Avg. Speed 38Mbps, Unlimited
    Gift: None
  • Plusnet £22.99 (*35.98)
    Avg. Speed 36Mbps, Unlimited
    Gift: £75 Reward Card
Prices inc. Line Rental | View All
Helpful ISP Guides and Tips
»
»
»
»
»
»
»
»
»
»
»
»
»
»
»
»
»
»
»
»
»
»
»
»
»
»
»
»
»
Promotion
The Top 20 Category Tags
  1. BT (2739)
  2. FTTP (2660)
  3. FTTC (1766)
  4. Building Digital UK (1721)
  5. Politics (1629)
  6. Openreach (1588)
  7. Business (1402)
  8. FTTH (1329)
  9. Statistics (1219)
  10. Mobile Broadband (1195)
  11. Fibre Optic (1047)
  12. 4G (1026)
  13. Wireless Internet (1009)
  14. Ofcom Regulation (1003)
  15. Virgin Media (989)
  16. EE (678)
  17. Sky Broadband (661)
  18. TalkTalk (651)
  19. Vodafone (650)
  20. 5G (486)
Sponsored

Copyright © 1999 to Present - ISPreview.co.uk - All Rights Reserved - Terms  ,  Privacy and Cookie Policy  ,  Links  ,  Website Rules